Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

iSNS firewall exception has not been enabled.

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

iSNS firewall exception has not been enabled.

Postby guest » Fri Jan 30, 2009 3:45 pm

Hi,

I try to setup my iSNS server into all my iscsi systems.
this works fine on all of then except my Hyper-V server.
I type this command:
C:\>iscsicli addisnsserver <my isns server name>

and the result is:
Microsoft iSCSI Initiator Version 6.0 Build 6000
The operation cannot be performed since the Internet Storage Name Server (iSNS) firewall exception has not been enabled.

so I try to enable this firewall exception without success.
disabling the firewall himself doesn't help me too.

any idea how I can do this?

thanks.


Soumya Das Bhaumik [MSFT] - Posted on Friday, January 02, 2009 7:10:07 PM

are you seeing this on the physical machine or the virtual machine?

--------------------------------------------------------------------------------
This posting is provided "AS IS" with no warranties, and confers no rights
Reply
Quote
Post already rated
Willgart1 - Posted on Friday, January 02, 2009 8:05:00 PM

in Hyper-V, so the "physical" part...

accessing the firewall configuration remotly (so through a GUI interface) I don't see any firewall rule associated to the iSNS service or isns protocol.
So I really don't know how I can activate this functionality under Hyper-V?

Reply
Quote
Post already rated
AnswerMervyn ZhangMSFT, Moderator - Posted on Monday, January 05, 2009 1:59:12 AM

Hi,

Have you tried the GUI iSCSI Initiator tool? This GUI tool will help to configure Firewall settings.

If not, please click Start, click Administrative Tools, choose iSCSI Initiator. It will ask if you would like to configure Firewall setting, click Yes.

Switch to Discovery tab, is your iSNS server listed? If not, click Add button to add your iSNS server manually.

If the issue persists, please try the command below to configure Firewall manually.

Enabling Outgoing iSCSI Traffic for the initiator:

The following command enables iSCSI Initiator traffic outbound through the firewall on the machine running the iSCSI Software initiator:

netsh advfirewall firewall set rule "iSCSI Service (TCP-Out)" new enable=yes

The following command allows outbound traffic to use an iSNS server for target discovery

netsh advfirewall firewall>set rule "iSNS Server (TCP Out)" new enable=yes

Enabling inbound traffic on a server running iSNS Server:

netsh advfirewall firewall>set rule "iSNS Server (TCP In)" new enable=yes


For more information, please refer to the iSCSI user guide.
http://download.microsoft.com/download/ ... uGuide.doc

Thanks.

AnswerWillgart1 - Posted on Monday, January 05, 2009 6:49:04 AM

sorry abiut this: it's HYPER-V
there is no GUI interface available.

I'm not talking about Windows 2008 + Hyper-V.

your proposed solution doesn't works, trying to add the isns server still produce the error.
(i can finally edit the firewall setup remotely, and changing some of the firewall entries don't solve the issue)

but I have found a solution.
I edit the registry directly.I'm adding the isnsserver manually into the HKLM/Software/Microsoft/Windows NT/Current Version/Iscsi key.
after this, my hyper-v server is correctly listed into my isns server.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Fri Jan 30, 2009 6:38 pm

In our case, I receive this message when I iSCSI in my laptop running Vista. However, my XP desktop doesn't have this issue. Then I compare XP registry with Vista, the value of AllowiSNSFirewallException in HKLM/Software/Microsoft/Windows NT/Current Version/iSCSI is set to 0. After I change it to 1. It works.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm


Return to Networking

Your Ad Here

Who is online

Users browsing this forum: Exabot [Bot] and 6 guests