Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

DFS is not working anymore

Active Directory, Domain, DNS, WINS, DHCP, SBS, New Releases.

DFS is not working anymore

Postby guest » Thu Jul 29, 2010 11:06 am

DFS was configured and working fine on Server 2008 STD, but now it's no longer replicating. Here are some of the errors I am seeing:

---------------------------------------------------------------------------------------
- Due to the following error, the DFS Replication reporting mechanism cannot access the WMI (Windows Management Instrumentation) namespace to retrieve certain reporting information. Error ID: 0x80041002.

- DFS Replication cannot replicate with partner <server name> for replication group <domain>\<name space>\<share>. The partner did not recognize the connection or the replication group configuration. The DFS Replication service used partner DNS name <server name>, IP address <the server ip>, and WINS address <server name> but failed with error ID: 9026 (The connection is invalid). Event ID: 5012

AND

- The DFS Replication service is stopping communication with partner <server name> for replication group Domain System Volume due to an error. The service will retry the connection periodically.

Additional Information:
Error: 1726 (The remote procedure call failed.)
Connection ID: 580D7FC3-873F-48CC-AFC1-73E96DFADCE2
Replication Group ID: ACA5FC8A-AA2E-4D40-8ECC-3A0A8F45E5F8
---------------------------------------------------------------------------------------

I also have noticed that there is a disabled sysvol in the replication area which belongs to an decommissioned server. Not sure if that would mess anything up or not since it is disabled (and not needed), but I can't get rid of it.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Re: DFS is not working anymore

Postby guest » Thu Jul 29, 2010 11:07 am

Hi Rollinz,


According to the research, the issue maybe occur because the DFS servers do not have the permission to read AD information on themselves or their partners.



1. Please open the ADSIedit.msc console to verify the "Authenticated Users" is set with the default READ permission on the following object:



a. The computer object of the DFS server



b. The DFSR-LocalSettings object under the DFS server computer object



2. After the permissions is set correct, please run "DFSRDIAG POLLAD" to pick up the changes.



Another possible reason is that FSRM is configured as some types of files are blocked from DFS replication. When the DFSR filters are not set to match FSRM screens by extension and the files exist on the server before screening, this can lead to degraded DFSR performance and the files will never replicate.



If possible, please remove file screening and reconfigure it to remove files by extension or set a comparable DFSR filter rule to prevent replication attempts.



Hope it helps.


--------------------------------------------------------------------------------
David Shen - MSFT
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Re: DFS is not working anymore

Postby guest » Thu Jul 29, 2010 11:07 am

You are the man David!

A few side notes for anyone else looking for a fix here:

- The file permissions were already set correctly in my case.
- I went into adsiedit.msc and updated the schema as well as verified in my Domain Controller list that DFS replication was good.
- I then ran the suggested "DFSRDIAG POLLAD".

One last critical step I had to do because I had deleted my DFS replication groups was to not only recreate them, but to first delete the "DfsPrivate" hidden folders that were left behind. For some reason mine were either corrupt, or the server never noticed they needed to be recreated. I got the following message in my event logs before deleting the DfsPrivate folders:

------------------------------------------------------------

The DFS Replication service failed to communicate with partner <server name> for replication <group_name>. The partner did not recognize the connection or the replication group configuration.

Partner DNS Address: <server.domain>

Optional data if available:
Partner WINS Address: <server>
Partner IP Address: x.x.x.x


The service will retry the connection periodically.

Additional Information:
Error: 9026 (The connection is invalid)
Connection ID: EE4A57A7-CC40-4156-BB08-1CE6B9348208
Replication Group ID: DFAC71DA-A412-4C10-8A6B-0D6198AEFD6B
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Re: DFS is not working anymore

Postby guest » Thu Jul 29, 2010 11:08 am

Hi,

I have had a similar issue while setting up DFS Replication and the replication reporting issued the Error ID: 0x80041002 and also Error: 9026 (The connection is invalid).

In my case I was able to resolve it by registering the MicrosoftDFS WMI namespace (I don't know if or why it has been de-registered or somehow stepped on).

Anyway maybe this helps you if you have the same issue

Open a CMD prompt in %windir%\system32\wbem

type mofcomp dfsrprovs.mof

net stop winmgmt
net start winmgmt
net start iphlpsvc
net stop dfsr
net start dfsr

Now it works (for me) and I hope for you !

Raymond
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm


Return to Windows

Your Ad Here

Who is online

Users browsing this forum: No registered users and 14 guests