Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Authentication error has occurred (Code: 0x80090330)

RRAS, VPN, TS/RDP, Routing and remote Access.

Authentication error has occurred (Code: 0x80090330)

Postby guest » Wed Jul 09, 2008 9:04 pm

Situation: When trying to use RDP6 connecting into a Vista. the client receives "An authentication error has occurred (Code: 0x80090330)." He has set to "Always connect, even if authentication fails." under the options on the RDP6.

If he enables the “enablecredsspsupport:i:0” option by adding it to the RDP file or use a machine with a pre-RDP6 client, it doesn't have a problem.

Cause: the client time and remote computer time are different.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby chicagotech » Thu Jul 10, 2008 8:39 am

Hi,

In Remote Desktop Connection 6.0, server authentication verifies that you
are connecting to the correct remote computer or server, which may lead to
some incompatibility issue.

So, could you confirm if you use Remote Desktop Connection 6.0 client to
connect Vista?

Before Vista, Remote Desktop Connection 6.0 has been included in the
following OS:

Microsoft Windows Server 2003 with Service Pack 1 (SP1)
Microsoft Windows Server 2003 with Service Pack 2 (SP2)
Microsoft Windows XP with Service Pack 2 (SP2)

If so, please edit Default.rdp file as following steps to turn off the new
features in Remote Desktop Connection 6.0 to revert to the features in
Remote Desktop Connection 5.x.

To do this, follow these steps:

1. Click Start, click Run, type mstsc.exe, and then click OK.
2. Click Options, and then click the General tab.
3. Click Save As, and then type a file name in the File name box.
4. Select the location where you want to save the remote desktop file,
click Save, and then click Cancel.

Note The saved file has the .rdp file name extension.
5. Click Start, click Run, type notepad, and then click OK.
6. On the File menu, click Open.
7. In the Files of type list, click All Files.
8. In the Look in list, locate and then click the file that you saved in
step 4. Then, click Open.
9. Locate the line that resembles the following:
authentication level:i:n
Note The n placeholder represents the current authentication level.
10. Change the authentication level to 0 so that the line becomes the
following:
authentication level:i:0
Note When you set the authentication level to 0, RDP 6.0 does not check for
server authentication.
11. Add the following line to the end of the file:
enablecredsspsupport:i:0
Note When this line is present, you do not have to provide credentials
before you establish a remote desktop connection.
12. On the File menu, click Save.
More information, please see:

Remote Desktop Connection 6.0 prompts you for credentials before you
establish a remote desktop connection
http://support.microsoft.com/kb/941641

In addition, please also install hotfixs for Remote Desktop Connection 6.0
client, which can be achieved from:

Remote Desktop Connection 6.0
http://technet2.microsoft.com/windowsvi ... 8-4e82-a32
c-4bc10ffe56ab1033.mspx?mfr=true

Please also test if you use RDC 5.0 to connect Vista, does this issue still
persist?

If you need further assistance, please post back with the latest
information.

Hope this helps.


Best wishes
--------------
Morgan Che

Sincerely
Morgan Che
Microsoft Online Support
Microsoft Global Technical Support Center

Get Secure! - www.microsoft.com/security
=====================================================
When responding to posts, please "Reply to Group" via your newsreader so
that others may learn and benefit from your issue.
=====================================================
This posting is provided "AS IS" with no warranties, and confers no rights.


--------------------
--->Thread-Topic: Problem remoting to vista enterprise system
--->thread-index: AcjiElodSI/IN9zOQ4a/aWZSsRYNfg==
--->X-WBNR-Posting-Host: 207.46.19.168
--->From: =?Utf-8?B?TGVtQGNvbW11bml0eS5ub3NwYW0=?= <Lem>
--->Subject: Problem remoting to vista enterprise system
--->Date: Wed, 9 Jul 2008 15:23:02 -0700
--->Lines: 14
--->Message-ID: <F806EB90>
--->MIME-Version: 1.0
--->Content-Type: text/plain;
---> charset="Utf-8"
--->Content-Transfer-Encoding: 7bit
--->X-Newsreader: Microsoft CDO for Windows 2000
--->Content-Class: urn:content-classes:message
--->Importance: normal
--->Priority: normal
--->X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.2992
--->Newsgroups: microsoft.public.windows.vista.networking_sharing
--->Path: TK2MSFTNGHUB02.phx.gbl
--->Xref: TK2MSFTNGHUB02.phx.gbl
microsoft.public.windows.vista.networking_sharing:29015
--->NNTP-Posting-Host: tk2msftibfm01.phx.gbl 10.40.244.149
--->X-Tomcat-NG: microsoft.public.windows.vista.networking_sharing
--->
--->I get an authentication error when I try to remote to my windows vista
system
--->using remote desktop. Every other system on the network responds just
fine
--->but connecting to the vista enterprise system is where the connection
gives
--->me an authentication error when trying to connect.
--->
--->Does anyone have any suggestions? I did change the time to match up
with the
--->server, also tried lowering the required securtiy level for remote
desktop
--->for vista, also the exact error is: an authentication error has
occurred
--->(code 0x80090330)
--->
--->It has worked before but once i had to reinstall vista then i was
unable to
--->connect. I also tried with different users and also made sure the
passwords
--->were the orrect ones, still no luck.
--->
--->
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 7066
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA


Return to VPN, TS and Remote Access

Your Ad Here

Who is online

Users browsing this forum: No registered users and 1 guest