Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Exchange 2007 incoming mail not working because of RGC

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

Exchange 2007 incoming mail not working because of RGC

Postby chicagotech » Thu Oct 25, 2007 4:13 pm

Q: We have Exchange 2003 on a single server, single domain and I am setting up
a new server with Exchange 2007. I can't get incoming mail to work on
accounts on the new server unless it is sent from another account on the
same server (I have one moved mailbox and one new mailbox on the Exchange
2007 server). It's acting like the receive connectors are not setup right
(to receive mail from the Exchange 2003 server) but I can't figure out what
is wrong with them. I even tried setting up another receive connector with
the IP of the Exchange 2003 server but that didn't help. Our Internet mail
goes to a Linux box running Qmail and then from there to the Exchange 2003
server. The event log showed the following error on 10/9/07 but I am no
longer seeing this error. In fact, I can't find any relevant errors now in
the event log on the Exchange 2007 server:

Event ID: 1035
Inbound authentication filaed with error IllegalMessage for Receive
connector Default EMERALD. The authentication mechanism is Gssapi. The
source IP address of the client who tried to authenticate to Microsoft
Exchange is [192.168.2.8].

Emerald is the Exchange 2007 server and 192.168.2.8 is the Exchange 2003
server.

I also tried using message tracking on both servers to see what happened to
the messages and that was no help either.

I've gone thru lots of articles on the Internet about Exchange 2007, how to
set it up, get mail working, etc. and I am drawing a blank at this time as
to what else to try. I can't figure out what is wrong. I did all the
preliminary stuff before installing to prepare AD, the schema, etc and ran
the Exchange 2007 readiness check. And when I run the BPA now, it doesn't
find any problems.

I did the below steps and noticed there was an error in the connector
configurations on the Exchange 2003 server because they were referring to an
SMTP connection on the Exchange 2003 server that is no longer in use (the
default one stopped working a couple of years ago so we created a new one
but did not delete the original one as I was afraid that would break
something). So when I did the steps below, I made sure to use the current
active SMTP connector when setting up the new connector. However, incoming
mail is still not working to users on the Exchange 2007 server. So I ran
WinRoute and Get-ReceiveConnector as instructed and will e-mail to you.

A: I believe that the Routing Group Connector is not configured correctly. To Re-create Routing Group Connectors, please follow these steps.

1. On Exchange 2003 server, start Exchange System Manager, and then remove
the existing two Routing Group Connectors under both the Exchange 2007 and
Exchange 2003 Administrative Groups.
2. After that, please expand the Administrative Group named "Denver",
expand the Routing Groups container, and then double-click the Routing
Group named "Denver".
2. Right-click the Connectors container, point to New, and then click
Routing Group Connector.
3. Type a name for this routing group connector.
4. Select the Exchange 2007 routing group under "Connects this routing
group with".
5. Configure a cost.

You can configure a cost from 1 to 100. Microsoft recommends that you
configure a cost that reflects both the physical cost of delivery and the
relative preference of using this connector over any other connector. By
default, routing group connectors are assigned the cost of 1, which makes
them the most likely connector to be used.

6. Select "These servers can send mail over this connector", click Add,
select the Exchange Server 2003 named "Pearl", and then click OK.
7. Click the Remote Bridgehead tab, click Add button, select the Exchange
2007 Hub Transport server named "Emerald ", and then click OK.
8. Click OK.
9. You are prompted to create the corresponding routing group connector in
the remote routing group. Click Yes to create this connector automatically.

After that, please restart the following service as well:

Microsoft Exchange Routing Engine service (RESvc)
SMTP service (SMTPSVC)
Microsoft Exchange MTA Stacks (MSExchangeMTA)

Then, please send an e-mail from a user whose mailbox is stored on Exchange
2003 server to a user whose mailbox is stored on Exchange 2007 server. What
is the result?

If the issue still occurs, please add the following registry value on
Exchange 2003 server:

Add SuppressStateChanges value
============================
1. Open a registry editor, such as Regedit.exe or Regedt32.exe.
2. Navigate to HKLM\System\CurrentControlSet\Services\RESvc\Parameters.
3. Right-click Parameters and select New | DWORD value. Name the new DWORD
value SuppressStateChanges.
4. Double-click SuppressStateChanges.
5. Set Base to Decimal.
6. In the Value data field, enter 1.
7. Close the registry editor and then restart the Simple Mail Transfer
Protocol (SMTP), the Microsoft Exchange Routing Engine, and the Microsoft
Exchange MTA Stacks services for the change to take effect.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6872
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Return to Networking

Your Ad Here

Who is online

Users browsing this forum: No registered users and 12 guests