Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Authentication to WSS site fails in Internet access

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

Authentication to WSS site fails in Internet access

Postby guest » Wed May 07, 2008 4:20 pm

Q: the authentication to the SharePoint site fails when the
users browse it from the Internet using the Internet URL. You've configured
port forwarding on the firewall for this site.

A: Based on my knowledge, it appears that this is not an Alternative Access
Mapping setting problem, but a Kerberos authentication problem.

For test purpose, please access this SharePoint site using the URL:
https://sharepoint.company.com/default.aspx to open the home page. If you
can access this site by using this URL, it indicates that this issue can be
caused by the AAM settings. If not, it is typically a Kerberos
authentication problem.

I'd like to clarify that when a user accesses a site on which Kerberos
authentication is configured, he first needs to communicate with KDC in the
domain prior to accessing the site to request a ticket for authentication.
For an Internet user, he may be unable to connect to the KDC in the domain
where the site is located to get the ticket since the connection could be
blocked by the firewall or something else, then he is unable to
authenticate against the SharePoint site. Actually, we don't recommend
deploying Kerberos authentication for the Internet access scenario.
Instead, it is only a preferable authentication protocol for Intranet
authentication to Internet Information Services (IIS).

More information
How the Kerberos Version 5 Authentication Protocol Works
http://technet2.microsoft.com/windowsse ... 5c-44ea-a0

To resolve this issue, I suggest you extend the WSS 3 site to another IIS
website on which you set to use NTLM authentication protocol.

You may refer to the following TechNet article to learn how to extend a web

Extend a Web application to host the same content as another Web application
http://technet2.microsoft.com/Office/en ... a01-89e9-d

You also need to add the appropriate rules to the AAM settings for this web

Plan alternate access mappings (Windows SharePoint Services)
http://technet2.microsoft.com/windowsse ... e-5162-46a
Tablet and Smartphone Setup Guide

Troubleshooting Vista Wireless
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Redirected to HTTP when you logon with HTTPS

Postby guest » Wed May 07, 2008 4:27 pm

Situation: You are redirected to HTTP URL when you logon with HTTPS URL. If this is not
correct, please let me know.

Based on my experience, this issue can occur if you don't have the
https://intranet.companyname.com URL in the AAM list.

Alternate access mapping (AAM) is a Windows SharePoint Services 3.0 feature
that allows users from different domains and networks to access the same
content using different URLs. Windows SharePoint Services determines where
a request originates from and then maps URLs appropriately for the
originating user.

At the most basic level, AAM tells SharePoint how to map web requests (for
example, browsing to the homepage of a SharePoint site) to the correct web
application and site so that SharePoint can serve the correct content back
to you. It then tells SharePoint what URL the users should be taken to as
they interact with SharePoint.

To configure the AAM, follow the steps below:

1. Locate to SharePoint Central Administration.
2. Click on Operations > Global Configuration > Alternate access mappings.
3. Click on "Edit Public URLs", and select the correct site collection
after "Alternate Access Mapping Collection".
4. Specify the URLs for intranet, extranet, Internet, and custom URLs.

So in our case, you should add https://intranet.companyname.com to a zone
such as Extranet.
Tablet and Smartphone Setup Guide

Troubleshooting Vista Wireless
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Return to Networking

Your Ad Here

Who is online

Users browsing this forum: Google [Bot] and 4 guests