Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

RDP won't connect after installing XP SP3

RRAS, VPN, TS/RDP, Routing and remote Access.

RDP won't connect after installing XP SP3

Postby chicagotech » Thu May 29, 2008 3:12 pm

I'm having the exact same issue. I don't think it happened right after
installing SP3 for XP so that shouldn't be the issue. And, frankly, VNC
sucks so I want my RDC back x.x Anyone have any other ideas?

"Trond Svendsen" wrote:

> Afraid not, it has been working flawlessy for weeks, and without any apparnt
> changes/updates, it stopped working at all. I don't get any error messages,
> the client just blinks "Connecting to xxx.xxx.xxx.xxx" and then dissapears
> without any error message.
>
>
>
>
> "Robert L. (MS-MVP)" <findemail> wrote in message
> news:usGzz1UvIHA.5520@TK2MSFTNGP06.phx.gbl...
> > It could be MTU issue. This search result may help.
> > connection to remote computer was broken caused by network error
> > If the Remote Desktop screen comes up black and then you receive this
> > error, you may need test and modify the MTU. These links may help, ...
> > www.chicagotech.net/Q&A/vpn54.htm
> >
> >
> > --
> > Bob Lin, MS-MVP, MCSE & CNE
> > Networking, Internet, Routing, VPN Troubleshooting on
> > http://www.ChicagoTech.net
> > How to Setup Windows, Network, VPN & Remote Access on
> > http://www.HowToNetworking.com

> >> Suddenly RDP won't connect. I'm running two machines on WinXP SP3 32-bit,
> >> and suddenly, yesterday, RDP won't connect.
> >>
> >> I don't get any error message, RDP just blinks "Connecting to
> >> xxx.xxx.xxx.xxx" and then dissapears without any error message. I've
> >> tried three different computers (all running WinXP SP3), and none of them
> >> connecting to this one specific host. These clients can connect to each
> >> other via RDP without any problem.
> >>
> >> I've checked the event log on the problematic server, but there is no
> >> clue as to what can be the problem. I've also tried to reboot this
> >> server, but there is no improvment.
> >>
> >>
> >> Regards
> >> Trond Svendsen
Last edited by chicagotech on Fri Jan 02, 2009 10:28 am, edited 1 time in total.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6670
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Thu May 29, 2008 3:14 pm

This could be a driver issue. this post may help.

RDPDD.dll failed to load with event ID 26
http://www.chicagotech.net/netforums/vi ... php?t=4148
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6670
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Fri Jan 02, 2009 10:28 am

Some XP may not be able to get RDP work after installing Service Pack 3 (SP3) on Windows XP machines due to the ActiveX control being disabled by default. It can be enabled by the following method:
Click on Tools -> Manage Add-Ons -> Enable or Disable Add-Ons in IE to enable the Terminal Services ActiveX control. If you are unable to do so, you may try to delete the following registry keys:
HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{7390f3d8-0439-4c05-91e3-cf5cb290c3d0} HKCU\Software\Microsoft\Windows\CurrentVersion\Ext\Settings\{4eb89ff4-7f78-4a0f-8b8d-2bf02e94e4b2)
Once you delete these keys, the activeX control should be enabled in IE7.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6670
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby guest » Fri Jan 02, 2009 2:42 pm

When trying to connect to a remote system through Remote Web Workplace,
the following error was received:

***********
This portion of the Remote Web Workplace requires the Microsoft Remote
Desktop ActiveX Control. Your browser's security settings may be
preventing you from downloading ActiveX controls. Adjust these settings
and try to connect again
***********

If I have misunderstood about your concern, please feel free to let me know.

This issue can occur if the kill bit is set for the Microsoft Remote
Desktop ActiveX Control on the machines connecting to RWW/RDP. This may be
caused by 3rd party antispywares, for example SpyBot S&D 1.4.

Based on the current situation, I suggest we perform the following steps to
troubleshoot the issue.

Step 1: Enable the "Do not save encrypted pages to disk" feature in
Internet Explorer on the client where you are browsing the RWW site from:

1. In Internet Explorer, click Internet Options on the Tools menu.
2. Click the Advanced tab. Scroll to the bottom. In the Security section,
click to check the "Do not save encrypted pages to disk" check box.
3. Click OK.

If this issue persists, let's perform Step 2.

Step 2: Modify the registry
==========
1. Click Start, click Run. Type "regedit" (without quotation mark) in the
open box and then press Enter.
2. Navigate to the following key:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\ActiveX
Compatibility\{7584C670-2274-4EFB-B00B-D6AABA6D3850}

3. Please first save it to your Desktop in case we need to recover it in
the future.

4. Delete the key.

Restart the computer and check the results.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm


Return to VPN, TS and Remote Access

Your Ad Here

Who is online

Users browsing this forum: No registered users and 4 guests