Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Windows XP cannot see Vista

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

Windows XP cannot see Vista

Postby ZZ_Scarab » Fri Nov 16, 2007 12:48 am

Hi,

I'm trying to network a Vista Ultimate computer and a WinXP Pro SP2. I'm running Windows Firewall and Norton Antivirus on the XP machine and Norton Internet Security (NIS) on the Vista machine. I added the XP's IP address to NIS, allowing inbound and outbound access, specifically opening ports 137, 138, 139 and 445 as per several articles I've read. I turned on all sharing options on Vista except for Sharing Public Folders. XP can see Vista and access its shared folders. The reverse is not so: Vista cannot even see XP at all, let alone access its shared folders. I can ping XP from Vista via the Command Prompt window, but cannot access it by typing its IP address into the address field in IE or Explorer. The XP machine is also visible and accessible from other XP, 2000 and Win98 machines. What else can I check?

Thanks
ZZ_Scarab
 
Posts: 3
Joined: Fri Nov 16, 2007 12:39 am

Postby chicagotech » Fri Nov 16, 2007 9:21 am

If turn off the firewall and Norton on the Vista, can you access XP?
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6873
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Windows XP cannot see Vista

Postby ZZ_Scarab » Fri Nov 16, 2007 12:27 pm

Yes, but that's not a viable option. Maybe there is a specific sequence of steps that would enable full two-way access followed by restoring the security afforded by the firewall. Do you think it's a Norton firewall issue that is not there with Windows firewall?
ZZ_Scarab
 
Posts: 3
Joined: Fri Nov 16, 2007 12:39 am

Postby chicagotech » Fri Nov 16, 2007 12:31 pm

I think it is Norton. To test it keep the windows firewall running and turn off the Norton. can you access XP?
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6873
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby ZZ_Scarab » Fri Nov 16, 2007 2:54 pm

Thanks. I'll try that if only just to test. If it turns out that Norton is indeed the problem, maybe the Symantec web site or forums will have an answer.
ZZ_Scarab
 
Posts: 3
Joined: Fri Nov 16, 2007 12:39 am

Re: Windows XP cannot see Vista

Postby guest » Tue Jun 16, 2009 8:37 am

This issue can be caused by incorrect system settings. Based on the current
situation, I suggest we perform the following steps to troubleshoot the
issue.

Step 1: Turn on Network Discovery and File and Printer Sharing of Windows
Vista
=======
1. Click "Start" and then click "Control Panel". Double click "Windows
Firewall".
2. Click "Change settings" and then click "Continue".
3. Click the "Exceptions" tab. Please select the following two options:

Network Discovery
File and Printer Sharing

4. Click Apply and then click OK.

Note: Please ensure Windows Vista and the Windows XP machine are in the
same workgroup. For example, we can use the default "Workgroup"

Step 2: Disable Windows Firewall on both Vista and XP machines
================
You may temporarily disable Windows Firewall to test the issue:

1. Click Start, click run, enter firewall.cpl in the open box and then
press enter.
2. Ensure Off is checked to test the issue.
3. Also, if other third party firewalls are enabled, please also disable
them to test the issue.

Step 3: Verify the NetBIOS over TCP/IP enabled on all machines
=====================

For Vista
+++++++
1. Right-click the Network in the Start menu to select Properties.
2. Click Manage network connections in the left pane to open it. Right
click "Local Area Connection" and then choose "Properties". Click
"Continue."
3. Point to Internet Protocol (TCP/IPv4), and then click Properties button.
4. Click Advanced button, click WINS tab, click to choose "Enable NetBIOS
over TCP/IP".
5. Click OK twice and then close it.

For XP
+++++++
1. Click Start, click Control Panel, and then click Network and Internet
Connections.
2. Click Network Connections.
3. Right-click Local Area Connection, and then click Properties.
4. Click Internet Protocol (TCP/IP), and then click Properties.
5. Click the General tab, and then click Advanced.
6. Click the WINS tab.
7. Under NetBIOS setting, click Enable NetBIOS over TCP/IP, and then click
OK two times.
8. Click Close to close the Local Area Connection Properties dialog box.
9. Close the Network Connections window.

Step 4: Verify the services on all machines
=====================
1. Click Start, click Run, enter services.msc in the open box and then
press Enter.
2. In the right details pane, verify that the Computer Browser service is
started, right-click Computer Browser, and then click Start.
3. Verify the following services are started and the startup type is
Automatic:

TCP/IP NetBIOS Helper
Workstation
Server

After performing the steps above, please reboot the computer and check the
results. If this issue persists, let's try the following steps.

Step 5: Check group policy on all workstations
==========
Note: Please perform the following steps on all workstations.

1. Go to Start > Run, type GPEDIT.MSC and click OK.
2. Browse to: Computer Configuration -> Windows Settings -> Security
Settings -> Local Settings -> User Rights Assignment
3. Find the "Access this computer for the network" in the right pane.
4. Make sure that Everyone is in the list. If not add the group to the list
and reboot the computer.
5. Find the "Deny access to this computer for the network", remove any
account in it.
6. Browse to: Computer Configuration -> Windows Settings -> Security
Settings -> Local Settings -> Security Option.
7. Please ensure the option "Network Access: Do not Allow anonymous
enumeration of SAM accounts and shares" are set to "Disabled"
8. Please also ensure the option "Network security: LAN Manager
authentication Level" is set to "Send LM & NTLM responses"
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm


Return to Networking

Your Ad Here

Who is online

Users browsing this forum: Google [Bot] and 9 guests