Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Vista: "Destination Folder Access Denied"

Permissions, Group Policy, IPSec, Virus, Spam, Spyware, Malware.

Vista: "Destination Folder Access Denied"

Postby bj33790 » Sat Mar 31, 2007 9:26 am

Hi, I have read all the help files on here but still have a problem...

I am running Vista Ultimate on one PC and XP Pro SP2 on another. I am the only user and have full admin rights on both (I checked) They are connected by a wired home network. I can see and browse the XP PC from the Vista PC, install programs from the XP PC onto the Vista PC - no problem BUT.... when I am using the Vista PC and try to copy a file across from the XP PC I can see the file appear in the Vista folder window (using drag & drop) but then I get the dreaded "Destination Folder Acess Denied....You need permission to perform this action" you can only click 'RETRY.' or 'CANCEL'....of course 'RETRY' just repeats the error window and 'CANCEL' removes the file that you have dropped into the destination folder. As I am the owner with full rights over the folder I dont understand what it needs
I tried removing any anti virus software, turning off the firewalls. I have tried everything I can think of to give me permission to copy files to my own folders from across the network, even giving myself full rights of the whole of the C: drive on the Vista PC and XP PC I then tried copying the file from the XP PC to a USB 'Zip key' and then plugged the 'USB Zip key' into the Vista PC. This works ok, it lets me copy the file from this to any folder I want on the Vista PC. ( I guess thats one way to do it but slow and tedious) ............so it is something to do with copying a file across the network, but surely we all want to that at some time....but it somehow needs more permission. Does anyone know how to set this to work please?

thanks in hopeful anticipation.....
[/b]
bj33790
 
Posts: 2
Joined: Sat Mar 31, 2007 8:53 am

Postby chicagotech » Sat Mar 31, 2007 10:17 am

Sounds like permission issue. Assuming you assign permissions in the Security tab, it could be ownership issue. Try this command: icacls %1 /grant username:F /t (here the username is logon name).
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby bj33790 » Sat Mar 31, 2007 11:17 am

icacls %1 /grant username:F /t (here the username is logon name).




Thanks for the reply Chicagotech,

I tried that but when I substitute my username (john), it replies with the error Invalid Parameter "john"........Am I missing something in the syntax?
bj33790
 
Posts: 2
Joined: Sat Mar 31, 2007 8:53 am

Postby chicagotech » Sat Mar 31, 2007 8:12 pm

How to take ownership of a file or folder in Windows
http://www.howtonetworking.com/Security ... rship4.htm

Can't edit data even administrator
The administrator may lost the ownership of the folder. To do take over the ownership, right click on the file or folder. ...
http://www.chicagotech.net/Security/ownership2.htm
Last edited by chicagotech on Thu Dec 06, 2007 7:02 pm, edited 1 time in total.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Mon Jul 30, 2007 8:14 am

Just purchased a vista business HP machine. Machine is part of an internal network. If I try to copy file from any other machine on the network from the VISTA machine, it gives me message "Destination Folder Access Denied" "You Need Permission to Perform this action". But I can copy the files from other machines on the network to the VISTA machine?????????

The problem in my case was permissions on the source file (Duh!).

Unknown to me, Administrator access had been limited to listing the files in that folder. Once I set the permissions correctly, the file copied as expected. This was not done intentially by the user but something happened to the permissions when the files were copied from a unix-based file source.

I'm somewhat embarrassed but wonder why the error message said "destination folder access denied" when it was clearly the source folder that had issues.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Wed Aug 01, 2007 8:19 am

Since enabling guest works, that approve this is security issue. However, we don't recommended to enable guest account, so that you may want to create same username and password on the both computers. This link may help,

Vista common issue - can see but ...1. Enable guest account that is not recommended for the security reason. 2. Assign everyone full rights in the Security tab that is no secure too. ...
http://www.chicagotech.net/netforums/vi ... .php?t=450


Bob Lin, MS-MVP, MCSE & CNE
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
"Marcel Maessen" <marcel> wrote in message news:F570BC4C-FB87-424E-9889-EC7352A73707@microsoft.com...
OK, here's "A" solution I found in this community, although imho not a very
decent one.

I just added the "guest" account to the list of people who are allowed to
share the folder and files and gave this account all necessary permissions
and now I can access the shared folders.

So much for Vista increased security, or am I wrong? For now, it's the only
solution that works.

Anyway; Thanks for your help, Robert.

"Robert L [MVP - Networking]" wrote:

> This how to may help,
>
> Vista How toHow to: disable Vista password protected sharing ... Post Posted: Wed Feb 07, 2007 3:23 am Post subject: How to: disable Vista password protected sharing . ...
> http://www.howtonetworking.com/vista/vista.htm
>
>
> Bob Lin, MS-MVP, MCSE & CNE
> Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
> How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
> "Marcel Maessen" <marcel> wrote in message news:E1348649-7906-45ED-BD23-F44047FE54C8@microsoft.com...
> I think I have, but how can I grant access to a user on a different computer?
> I have not been able to find that part of the sharing setup.
>
> Thanks for your answer
>
> "Robert L [MVP - Networking]" wrote:
>
> > Open the properties of the shared folder and check the Security tab. Have you assign permission there? Please post back.
> >
> > Bob Lin, MS-MVP, MCSE & CNE
> > Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
> > How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
> > "Marcel Maessen" <marcel> wrote in message news:3F23C48F-C0DE-4826-8919-FD029F8A7F7A@microsoft.com...
> > OK, here's the setup:
> >
> > Two laptops running on Vista Home premium, connected to the internet and
> > eachother by a router/Switch.
> >
> > All settings from the firewall are correct, since I can see the folders I
> > shared on either PC.
> >
> > The thing is, though, that once I click on the shared folders I get the
> > error message " \\machine\shared_folder is not accessible. You probably don't
> > have the proper credentials top access this networksource. Contact the
> > administrator to find out if you have the right credentials. ACCESS DENIED"
> >
> > Now, what did I do wrong and how can I correct this problem?
> >
> > Sure, I have to grant access to the user on the other computer, but how??
> >
> > Please help!
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

destination folder access denied from xp to vista

Postby secor941 » Wed Dec 05, 2007 9:36 pm

I was having the same problem of copying or accessing files on an xp computer with a vista computer, after about an hour of playing with different settings i finally figured it out.
this is what fixed my problem

first off you need to disable simple file sharing with xp
then right click the folder you want to transfer files out of
next click sharing and security, or properties. then go to the security tab and click advanced
(if not already listed) click add and type "Everyone" then select ok
then click on "everyone" and select edit.
then check the full control option. click ok
then finally place a check in the bottom box that says replace permission entries........
then click ok and you should be able to access ur xp files from the vista pc
secor941
 
Posts: 3
Joined: Wed Dec 05, 2007 9:03 pm
Location: Iowa

Postby chicagotech » Thu Dec 06, 2007 12:34 am

Thank you for the input.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

access denied

Postby secor941 » Fri Dec 07, 2007 1:41 pm

Ive found that each time I download a file to my shared folder I have to go and change permissions again and again and again to access new files, I guess by default windows doesnt allow full permission for everyone so u gotta go through and allow full control each time you add new files
secor941
 
Posts: 3
Joined: Wed Dec 05, 2007 9:03 pm
Location: Iowa

Postby chicagotech » Fri Dec 07, 2007 3:08 pm

In the Security tab of the folder, click Advanced, do you have Inherit from parent the permission entries that apply to child objects... checked?
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

access denied

Postby secor941 » Sat Dec 08, 2007 3:38 pm

yes it's checked
secor941
 
Posts: 3
Joined: Wed Dec 05, 2007 9:03 pm
Location: Iowa

Postby chicagotech » Wed Dec 12, 2007 11:59 am

Based on Microsoft article: How permissions are handled when you copy and move files and folders

"When you copy or move a file or folder on an NTFS volume, how Windows Explorer handles the permissions on the object varies, depending on whether the object is copied or moved within the same NTFS volume or to a different volume."

"By default, an object inherits permissions from its parent object, either at the time of creation or when it is copied or moved to its parent folder. The only exception to this rule occurs when you move an object to a different folder on the same volume."

You may want to check the article for more details: http://support.microsoft.com/kb/310316
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Wed Dec 12, 2007 12:01 pm

Here is another post:

Richard wrote:
> My wife's computer and my computer are connected via our LAN router (and thence
> to the Internet). Her computer is running XP Home and mine XP Professional. I
> set up a shared folder on my computer so that she could store some files there
> and free up some disk space.
>
> She can transfer files through the LAN to the shared folder on my computer. She
> also can read these files OK and copy them back to her computer.
>
> I downloaded a couple of files from the Internet into this directory. The files
> are .zip archives. I can read these files OK, but she can not access them
> through the LAN. Any attempt to copy one of these files to her computer or to
> open a .zip file by double-clicking results in the error message:
>
> "Access to <file> is denied.
>
> I created a small .txt file in this folder, and she was able to access the .txt
> file. So her ability to access a file doesn't depend on who put it there.
>
> On my computer, in Windows Explorer, when I select this folder and click on the
> menu item Tools | Folder Options and select the View tab, the advanced setting
> "Use simple file sharing" is checked. Shouldn't this setting let her access
> anything in the shared folder.
>
> What is wrong?

What probably has happened is that when you downloaded the files, they
initially were stored in your browser's cache and then copied
(automatically) to the directory you specified. You never shared your
browser's cache (why would you?).

According to KB310316, "By default, an object inherits permissions from
its parent object, either at the time of creation or when it is copied
or moved to its parent folder. The only exception to this rule occurs
when you move an object to a different folder on the same volume. In
this case, the original permissions are retained."

Thus, even though the file appears to be in a directory for which your
wife's account has access permission, it has inherited the original
permissions (which did not include access for your wife's account) from
the temporary directory in which it was created.

First ensure that Simple File Sharing is turned off (if you don't know
how, see http://support.microsoft.com/kb/307874/).

To check that this is in fact the problem, compare the permissions for a
file that is sharable with one that isn't.

Right-click on a file, select Properties, and then the Security tab. If
you compare the permissions for a file that does not have the problem
with one that does, you should see the difference (probably "Everyone"
does not have rights to the problem files). In the "Advanced" screen,
make sure that the box to "Inherit from parent the permission entries
that apply to child objects" is checked (this is the default).

Now, right-click the *folder* in which the shared files are stored and
go to the Security tab. Click the "Advanced" button. This time, there
should be a second box to "Replace permission entries on all child
objects with entries shown here that apply to child objects." Check this
and OK out (note that this operation can't be undone).

After you're done, you can turn Simple File Sharing back on, if that's
how you normally had things set up (it's the default in XP Pro).
--
Lem -- MS-MVP - Networking
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Tue Feb 19, 2008 5:45 pm

Also check this post.

You need permission to perform this action
http://www.chicagotech.net/netforums/vi ... =5281#5281
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6992
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA


Return to Security

Your Ad Here

Who is online

Users browsing this forum: No registered users and 1 guest