Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Wireless: was unable to find a certificate to log you on

Wi-Fi, Mobile phone.

Wireless: was unable to find a certificate to log you on

Postby chicagotech » Fri Apr 06, 2007 11:26 am

Situation: 1. when using WPA Enterprise, you may receive this Error: Windows was unable to find a certificate to log you on to the network chicagotechwireless.

2. The wireless connection shows "Security-enabled wireless network (WPA). You are currently connected to this network", but you can't access any other networking devices and the Internet. The Ipconfig displays IP is 0.0.0.0.

3. The wireless icon has a red ? mark.

Causes: 1. You haven't logon the domain network.
2. You logon local computer.
3. The certificate doesn't match or need to install.
4. You are not allowed to access the wireless.
5. Make sure you have correct authentication type. We have a case, the EAP type should be Protected EAP (PEAP) but the default is Smart Card or other Certificate.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6934
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Tue Sep 16, 2008 10:41 am

That error message can pop up if you're running IEEE 802.1x authentication, but are not actually in a 802.1x (EAP) environment.

Please go to Start --> Programs --> Accessories --> Communications --> Network Connections --> Right-click your Connection and select Properties --> Click on the Authentication tab --> Disable / uncheck the option IEEE 802.1x authentication for this network. Now, try to connect to your Wireless network; are you able to? (Note: you may need to restart the computer.)
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 6934
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby guest » Tue Sep 16, 2008 10:43 am

The reason we got into this mess was because we just enabled WPA-PSK on our router.

He has an Averitec Laptop, and had some broadcom software that was conflicting with the built in Windows software. I removed the broadcom software and uninstalled the wifi drivers, rebooted, and let the windows automagical install take care of things.

Now there is no conflict and the thing can connect.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Tue Sep 16, 2008 10:45 am

This is caused by setting the encryption to WPA-RADIUS instead of
WPA-PSK on the client radio. Both the router and the client are
trying to find a RADIUS server with which to authenticate your system.
Switch the encryption to WPA-PSK (pre-shared key) on both ends and it
will work.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Tue Sep 16, 2008 10:49 am

Trouble is, the option is greyed out if I select WPA-PSK (TKIP or EAS).
It can be selected only if select "WPA - professional"...
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Tue Sep 16, 2008 10:50 am

I removed the latest driver for the DWA-645 card, and re-installed from
the CD, along with the D-link wireless utility.

I disabled the windows wireless zero configuration, and configured the
encryption to WPA2-PSK (AES), with now a perfectly working setup and no
more warning bubbles. And 300Mbps is availbale even with WPA-PSK (TKIP)
now, while it sed to fall back to 54 Mbps with the "latest driver" from
D-link Finland.

Thanks to all for your input.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Tue Sep 16, 2008 10:51 am

I had this same problem after installing the software for a new router. I uninstalled the software that came with it and then reinstalled it (im NOW using their software to control my wireless connection not windows) and now all is well, the certificate bubble is gone! THANK GOODNESS! Arrgh that was annoying so.....try that. Hope it helps!
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Tue Sep 16, 2008 10:54 am

I fixed this error by install Microsoft Wireless Client Update -
Description of the Wireless Client Update for Windows XP with Service Pack 2: http://support.microsoft.com/?kbid=917021
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Postby guest » Wed Jan 21, 2009 12:31 pm

I had the same problem. i found whenever my laptop installs MS upadte, the EAP type reset to the default which is Smart Card or other Certificate.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm


Return to Wireless

Your Ad Here

Who is online

Users browsing this forum: No registered users and 2 guests