Home | Site Map | Cisco How To Net How To | Wireless | Search | Forums | Services | Setup Guide | Careers | About Us | Contact Us|

 

Exchange 2010 Replication Copy Status: Failed and Suspected, Disconnected and Resynchronizing

 

We have an Exchange 2010 clustering environment with 4 Virtual Machines in 2 Hyper-V servers. The 4 Exchange servers are exch-mail01, exch-mail02, exch-xas01 and exch-cas02. We have a replication issue and the Copy Status shows Failed and Suspected, Disconnected and Resynchronizing as shown below screenshots.

 

 

If we run Activate Database Copy, we get this message:

Microsoft Exchange Error

--------------------------------------------------------

Cannot activate database copy 'Activate Database Copy...'.

Activate Database Copy...

Failed

Error:

An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: Database copy 'Exec Database 1' on server 'EXCH-MAIL01.chicagotech.nethas a copy queue length of 459 logs, which is too high to enable automatic recovery. You can use the Move-ActiveMailboxDatabase cmdlet with the -SkipLagChecks and -MountDialOverride parameters to move the database with loss. If the database isn't mounted after successfully running Move-ActiveMailboxDatabase, use the Mount-Database cmdlet to mount the database.. [Database: Exec Database 1, Server: EXCH-MAIL02.chicagobotanic.org]

An Active Manager operation failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: Database copy 'Exec Database 1' on server 'EXCH-MAIL01.chicagotech.nethas a copy queue length of 459 logs, which is too high to enable automatic recovery. You can use the Move-ActiveMailboxDatabase cmdlet with the -SkipLagChecks and -MountDialOverride parameters to move the database with loss. If the database isn't mounted after successfully running Move-ActiveMailboxDatabase, use the Mount-Database cmdlet to mount the database..

Here are the result of  test-replicationhealth

[PS] C:\Windows\system32>test-replicationhealth

Server Check Result Error

------ ----- ------ -----

EXCH-MAIL01 ClusterService Passed

EXCH-MAIL01 ReplayService Passed

EXCH-MAIL01 ActiveManager Passed

EXCH-MAIL01 TasksRpcListener Passed

EXCH-MAIL01 TcpListener Passed

EXCH-MAIL01 DagMembersUp Passed

EXCH-MAIL01 ClusterNetwork Passed

EXCH-MAIL01 QuorumGroup Passed

EXCH-MAIL01 FileShareQuorum Passed

EXCH-MAIL01 DBCopySuspended *FAILED* Continuous Replication for Database 'Users Database 1\EXCH-MAI...

EXCH-MAIL01 DBCopyFailed Passed

EXCH-MAIL01 DBInitializing Passed

EXCH-MAIL01 DBDisconnected *FAILED* Continuous Replication for database 'Exec Database 1\EXCH-MAIL...

EXCH-MAIL01 DBLogCopyKeepingUp Passed

EXCH-MAIL01 DBLogReplayKeepingUp Passed

 

 

Post your questions, comments, feedbacks and suggestions

Contact a consultant

Related Topics